Personal Blog of Thomas Hampel - Creative Mythbusting in Development and Collaboration

Query results for : Websphere

Websphere Plugin Customization Toolkit does not start- 7 January 2014 - (0) Comments

Thomas Hampel
 7 January 2014

Working with IBM Websphere 8.5.5 on Linux, in my case CentOS,  I ran into an issue where the Websphere Customization Toolbox did not start.
Trying to use the console command to start it ( /opt/IBM/WebSphere/Toolbox/WCT/wct.sh ) did not provide any further information about the problem.

So lets have a look into the recent logs
#tail /var/logs/messages


Which showed some warnings... :  [ warning] [Gtk] Unable to locate theme engine in module_path: "clearlooks"

One suggestion to address this issue is to install gtk2-engines in a 32bit version, so lets try that....
# yum install gtk2-engines.i686


The next attempt to start the Toolkit brought more details, this time with a reference to a log file
Image:Websphere Plugin Customization Toolkit does not start

Looking into this log file ( /root/.ibm/WebSphere/workspaces/WCT85/.metadata/.log  ) revealed a missing library.

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        /root/.ibm/WebSphere/configurations/WCT85/org.eclipse.osgi/bundles/45/1/.cp/libswt-pi-gtk-3659.so (libXtst.so.6: cannot open shared object file: No such file or directory)


Solution
Bottom line, the solution was to install those two packages
  • # yum install gtk2-engines.i686
  • # yum install libXtst.i686
Finally the Customization Toolbox started up and is working fine..
Go ElsewhereSubscribe to RSSAboutStay ConnectedAnd More
Thomas Hampel, All rights reserved.